System requirements#

Software dependency

  • python >= 3.6.0

  • pytorch >= 1.12.0

  • pybedtools >= 0.9.0

  • gffutils >= 0.10.0

  • pybind11 >= 2.10.0

Version warning

Splam is currently not compatible with the latest version of python=3.11.4 due to a dependency issue with pybedtools. We are currently investigating and will patch in a future update. In the meantime, we recommend running in a python=3.10 environment, as shown below

$ conda create -n myenv python=3.10

There are three ways that you can install Splam:

Install through pip#

Splam is on PyPi 3.12 now. Check out all the releases here. Pip automatically resolves and installs any dependencies required by Splam.

$ pip install splam

Install from source#

You can also install Splam from source. Check out the latest version on GitHub !

$ git clone --recursive

$ cd splam/src/

$ python install

Install through conda#

Installing Splam through conda is the easiest way to go:


$ conda install -c bioconda splam

Check Splam installation#

Run the following command to make sure Splam is properly installed:

$ splam -h

Now, you are ready to go !#

Please continue to the Quick Start Guide.